RenderingSettings Class

RenderingSettings Class

Represents the rendering settings for a 3d view.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderingSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RenderingSettings : IDisposable
Public Class RenderingSettings
	Implements IDisposable
public ref class RenderingSettings : IDisposable
type RenderingSettings = 
    class
        interface IDisposable
    end

The RenderingSettings type exposes the following members.

Properties
 NameDescription
Public propertyBackgroundStyle The enum value that controls the background style for rendering.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLightingSource The lighting scheme type.
Public propertyPrinterResolution The resolution level when using printer.
Public propertyResolutionTarget The resolution target.
Public propertyResolutionValue The rendering resolution in dots per inch (DPI).
Public propertyUsesRegionRendering The bool value that indicates whether to use region rendering.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RenderingSettings
Public methodGetBackgroundSettings Returns an object that represents the rendering background settings.
Public methodGetRenderingImageExposureSettings Returns an object that represents the rendering image exposure settings.
Public methodGetRenderingQualitySettings Returns an object that represents the rendering quality settings.
Public methodGetRenderingRegionOutline Returns the outline of the rendering region.
Public methodSetBackgroundSettings Changes the rendering background settings details for the current background style.
Public methodSetRenderingImageExposureSettings Changes the rendering image exposure settings.
Public methodSetRenderingQualitySettings Change rendering quality settings.
Top
See Also