Revit 2025.3 API
DocumentRemove |
Remove the material painted on the element's face.
If the face is currently not painted,it will do nothing.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void RemovePaint( ElementId elementId, Face face )
Public Sub RemovePaint ( elementId As ElementId, face As Face )
public: void RemovePaint( ElementId^ elementId, Face^ face )
member RemovePaint : elementId : ElementId * face : Face -> unit
Parameters

Exception | Condition |
---|---|
ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element |
ArgumentNullException | A non-optional argument was null |
See Also