Revit 2025.3 API
External |
Checks whether the reference is in a valid format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsValidReference( ExternalResourceType resourceType )
Public Function IsValidReference ( resourceType As ExternalResourceType ) As Boolean
public: bool IsValidReference( ExternalResourceType^ resourceType )
member IsValidReference : resourceType : ExternalResourceType -> bool
Parameters
- resourceType ExternalResourceType
- The type of resource which the ExternalResourceReference should correspond to.
Return Value
BooleanTrue if this is a valid ExternalResourceReference. False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This function checks:
- The server id corresponds to a valid server which implements IExternalResourceServer.
- The server supports the given ExternalResourceType.
- The reference information is well-formed.
See Also