Revit 2025.3 API
Schedulable |
A non-calculated field eligible to be included in a schedule.

SystemObject
Autodesk.Revit.DBSchedulableField
Autodesk.Revit.DBSchedulableField
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The SchedulableField type exposes the following members.

Name | Description | |
---|---|---|
![]() | SchedulableField | Creates a new SchedulableField. |
![]() | SchedulableField(Guid) | Creates a new SchedulableField. |
![]() | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField. |
![]() | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField. |

Name | Description | |
---|---|---|
![]() | FieldType | The type of data displayed by the field. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ParameterId | The ID of the parameter displayed by the field. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SchedulableField |
![]() | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object)) |
![]() | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return . |
![]() | GetHashCode |
Gets the integer value of the SchedulableField as hash code
(Overrides ObjectGetHashCode) |
![]() | GetName | Gets the name of the field. |

Name | Description | |
---|---|---|
![]() ![]() | Equality(SchedulableField, SchedulableField) | Determines whether two SchedulableField are the same. |
![]() ![]() | Inequality(SchedulableField, SchedulableField) | Determines whether two SchedulableField are different. |

The SchedulableField class represents a non-calculated field that is
eligible to be included in a schedule. A list of fields that can be
included in a schedule can be obtained from
ScheduleDefinition.GetSchedulableFields.
See Also