PointOnEdgeEdgeIntersection Class

PointOnEdgeEdgeIntersection Class

Define a ReferencePoint at the intersection of two referenceable lines.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPointElementReference
    Autodesk.Revit.DBPointOnEdgeEdgeIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PointOnEdgeEdgeIntersection : PointElementReference
Public Class PointOnEdgeEdgeIntersection
	Inherits PointElementReference
public ref class PointOnEdgeEdgeIntersection : public PointElementReference
type PointOnEdgeEdgeIntersection = 
    class
        inherit PointElementReference
    end

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods
 NameDescription
Public methodGetEdgeReference1Get a copy of the first edge or curve reference.
Public methodGetEdgeReference2Get a copy of the second edge or curve reference.
Public methodSetEdgeReference1Change the first edge or curve reference.
Public methodSetEdgeReference2Change the second edge or curve reference.
Top
Remarks
The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.
See Also