PointOnEdgeEdgeIntersection.SetEdgeReference1 Method

PointOnEdgeEdgeIntersectionSetEdgeReference1 Method

Change the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetEdgeReference1(
	Reference edgeReference
)
Public Sub SetEdgeReference1 ( 
	edgeReference As Reference
)
public:
void SetEdgeReference1(
	Reference^ edgeReference
)
member SetEdgeReference1 : 
        edgeReference : Reference -> unit 

Parameters

edgeReference  Reference
 
Remarks
The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.
See Also