ViewSchedule.GetValidCategoriesForMaterialTakeoff Method

ViewScheduleGetValidCategoriesForMaterialTakeoff Method

Gets a list of categories that can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ICollection<ElementId> GetValidCategoriesForMaterialTakeoff()
Public Shared Function GetValidCategoriesForMaterialTakeoff As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetValidCategoriesForMaterialTakeoff()
static member GetValidCategoriesForMaterialTakeoff : unit -> ICollection<ElementId> 

Return Value

ICollectionElementId
The IDs of all valid categories.
See Also