ViewSchedule Class

ViewSchedule Class

A schedule view.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBView
      Autodesk.Revit.DBTableView
        Autodesk.Revit.DBViewSchedule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewSchedule : TableView
Public Class ViewSchedule
	Inherits TableView
public ref class ViewSchedule : public TableView
type ViewSchedule = 
    class
        inherit TableView
    end

The ViewSchedule type exposes the following members.

Properties
 NameDescription
Public propertyBodyTextTypeId Defines the default text style used for the data section of the schedule.
Public propertyDefinition The primary ScheduleDefinition.
Public propertyEmbeddedDefinition The embedded ScheduleDefinition.
Public propertyHasStripedRows Indicates whether this schedule has striped rows.
Public propertyHeaderTextTypeId Defines the default text style used in the column headers in the body section of the schedule.
Public propertyStatic memberIsHeaderFrozen A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.
Public propertyIsInternalKeynoteSchedule Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public propertyIsTitleblockRevisionSchedule Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public propertyKeyScheduleParameterName In a key schedule, the name of the parameter for choosing one of the keys.
Public propertyRowHeight Defines the schedule body rows height.
Public propertyRowHeightOverride Defines the override that is applied to the row height.
Public propertyTitleTextTypeId Defines the default text style used in the header section of the schedule.
Public propertyUseStripedRowsOnSheets Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.
Top
Methods
 NameDescription
Public methodCanGroupHeaders Indicates if selected headers can be grouped for this schedule.
Public methodCanUngroupHeaders Indicates if selected headers can be ungrouped.
Public methodStatic memberCreateKeynoteLegend Creates a keynote legend.
Public methodStatic memberCreateKeySchedule Create a key schedule.
Public methodStatic memberCreateMaterialTakeoff Creates a material takeoff.
Public methodStatic memberCreateNoteBlock Creates a note block.
Public methodStatic memberCreateRevisionSchedule Creates a revision schedule.
Public methodStatic memberCreateSchedule(Document, ElementId) Creates a regular schedule.
Public methodStatic memberCreateSchedule(Document, ElementId, ElementId) Creates a regular schedule that can relate to a specific area scheme.
Public methodStatic memberCreateSheetList Creates a sheet list.
Public methodStatic memberCreateViewList Creates a view list.
Public methodDeleteSegment Deletes a schedule segment.
Public methodExport Exports the schedule data to a text file.
Public methodStatic memberGetDefaultNameForKeynoteLegend Gets the default view name that will be used when creating a keynote legend.
Public methodStatic memberGetDefaultNameForKeySchedule Gets the default view name that will be used when creating a key schedule.
Public methodStatic memberGetDefaultNameForMaterialTakeoff Gets the default view name that will be used when creating a material takeoff.
Public methodStatic memberGetDefaultNameForNoteBlock Gets the default view name that will be used when creating a note block.
Public methodStatic memberGetDefaultNameForRevisionSchedule Gets the default view name that will be used when creating a revision schedule.
Public methodStatic memberGetDefaultNameForSchedule(Document, ElementId) Gets the default view name that will be used when creating a regular schedule.
Public methodStatic memberGetDefaultNameForSchedule(Document, ElementId, ElementId) Gets the default view name that will be used when creating a schedule.
Public methodStatic memberGetDefaultNameForSheetList Gets the default view name that will be used when creating a sheet list.
Public methodStatic memberGetDefaultNameForViewList Gets the default view name that will be used when creating a view list.
Public methodStatic memberGetDefaultParameterNameForKeySchedule Gets the default parameter name that will be used when creating a key schedule.
Public methodGetScheduleHeightsOnSheet Gets the heights of schedule title, column header and each schedule body row.
Public methodGetScheduleInstances Gets the instances ids of schedule or schedule segment.
Public methodGetSegmentCount Gets the total count of schedule segments.
Public methodGetSegmentHeight Gets the segment height.
Public methodGetStripedRowsColor Gets the color applied to part of the pattern for a schedule with striped rows.
Public methodGetTableData Gets the writable table data object.
Public methodStatic memberGetValidCategoriesForKeySchedule Gets a list of categories that can be used for a key schedule.
Public methodStatic memberGetValidCategoriesForMaterialTakeoff Gets a list of categories that can be used for a material takeoff.
Public methodStatic memberGetValidCategoriesForSchedule Gets a list of categories that can be used for a regular schedule.
Public methodStatic memberGetValidFamiliesForNoteBlock Gets a list of families that can be used for a note block.
Public methodGroupHeaders Groups schedule header cells.
Public methodHasImageField Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Public methodIsDataOutOfDate Indicates whether the schedule data is out of date.
Public methodIsSplit Checks if the schedule is split.
Public methodStatic memberIsValidCategoryForKeySchedule Checks whether a category can be used for a key schedule.
Public methodStatic memberIsValidCategoryForMaterialTakeoff Checks whether a category can be used for a material takeoff.
Public methodStatic memberIsValidCategoryForSchedule Checks whether a category can be used for a regular schedule.
Public methodStatic memberIsValidFamilyForNoteBlock Checks whether a family can be used for a note block.
Public methodIsValidTextTypeId Identifies if the input id represents a valid text type id for use in the schedule properties.
Public methodMergeSegments Merges two adjacent segments into one.
Public methodRefreshData Rebuilds the schedule data if it is out of date.
Public methodRestoreImageSize Restores all images to their original sizes.
Public methodSetSegmentHeight Sets the segment height.
Public methodSetStripedRowsColor Sets the color applied to part of the pattern for a schedule with striped rows.
Public methodSplit(IListDouble) 
Public methodSplit(Int32) Splits the schedule into several segments by given segment number.
Public methodSplitSegment 
Public methodUngroupHeaders Ungroups selected headers of schedule.
Top
Remarks

The ViewSchedule class represents schedules and other schedule-like views, including single-category and multi-category schedules, key schedules, material takeoffs, view lists, sheet lists, keynote legends, revision schedules, and note blocks. The ViewSchedule class is not used for panel schedules (see PanelScheduleView) or graphical column schedules.

A schedule is a tabular representation of data. A typical schedule shows all elements of a category (doors, rooms, etc.) with each row representing an element and each column representing a parameter. This basic structure can be modified using filters, sorting, grouping, totals, formulas, and other features.

The ScheduleDefinition class contains most settings that determine the contents of a schedule, including category, fields, filters, and sorting.

A graphical representation of a schedule can be placed on a sheet using the ScheduleSheetInstance class.

See Also