ViewSchedule.IsValidCategoryForSchedule Method

ViewScheduleIsValidCategoryForSchedule Method

Checks whether a category can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsValidCategoryForSchedule(
	ElementId categoryId
)
Public Shared Function IsValidCategoryForSchedule ( 
	categoryId As ElementId
) As Boolean
public:
static bool IsValidCategoryForSchedule(
	ElementId^ categoryId
)
static member IsValidCategoryForSchedule : 
        categoryId : ElementId -> bool 

Parameters

categoryId  ElementId
The category ID to check.

Return Value

Boolean
True if the category can be used for a regular schedule, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also