Revit 2025.3 API
Filled |
Check if the id is a FillPatternElement or an invalidElementId
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsValidFillPatternId( ElementId patternId )
Public Function IsValidFillPatternId ( patternId As ElementId ) As Boolean
public: bool IsValidFillPatternId( ElementId^ patternId )
member IsValidFillPatternId : patternId : ElementId -> bool
Parameters
- patternId ElementId
- Element id of the FillPatternElement
Return Value
BooleanTrue if the id is InvalidElementId, or if the element is a FillPatternElement. False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also