DirectShapeReferenceOptions.GetExternalGeometryId Method

DirectShapeReferenceOptionsGetExternalGeometryId Method

Retrieves the ExternalGeometryId associated with the reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ExternalGeometryId GetExternalGeometryId()
Public Function GetExternalGeometryId As ExternalGeometryId
public:
ExternalGeometryId^ GetExternalGeometryId()
member GetExternalGeometryId : unit -> ExternalGeometryId 

Return Value

ExternalGeometryId
Remarks
If an ExternalGeometryId has not been set, this method returns .
See Also