Revit 2025.3 API
TransformCreate |
Creates a transform that represents a rotation about the given axis at the specified point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Transform CreateRotationAtPoint( XYZ axis, double angle, XYZ origin )
Public Shared Function CreateRotationAtPoint ( axis As XYZ, angle As Double, origin As XYZ ) As Transform
public: static Transform^ CreateRotationAtPoint( XYZ^ axis, double angle, XYZ^ origin )
static member CreateRotationAtPoint : axis : XYZ * angle : float * origin : XYZ -> Transform
Parameters
Return Value
TransformThe new transform.

Exception | Condition |
---|---|
ArgumentException | The given value for angle is not finite |
ArgumentNullException | A non-optional argument was NULL |
ArgumentOutOfRangeException | axis has zero length. |
See Also