Revit 2025.3 API
Filter |
An instance of this class holds a filter operator and a text string that denotes
the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan
may be "is less than" for a filter rule based on a parameter with numerical values
or "is below" for a filter rule based on a parameter representing a Level.

SystemObject
Autodesk.Revit.DBFilterOperatorAndTextString
Autodesk.Revit.DBFilterOperatorAndTextString
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The FilterOperatorAndTextString type exposes the following members.

Name | Description | |
---|---|---|
![]() | FilterOperatorStr | A text string denoting the filter operator. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OperatorType | The filter operator. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FilterOperatorAndTextString |
See Also