Transform.AlmostEqual Method

TransformAlmostEqual Method

Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool AlmostEqual(
	Transform right
)
Public Function AlmostEqual ( 
	right As Transform
) As Boolean
public:
bool AlmostEqual(
	Transform^ right
)
member AlmostEqual : 
        right : Transform -> bool 

Parameters

right  Transform
The transformation to compare with this transformation.

Return Value

Boolean
True if the two transformations are equal; otherwise, false.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the specified transformation is .
Remarks
The tolerance is applied memberwise for comparison.
See Also