AnalyticalElement.MaterialId Property

AnalyticalElementMaterialId Property

Defines the Material Id for the Analytical Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
	Get
	Set
public:
property ElementId^ MaterialId {
	ElementId^ get ();
	void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The provided MaterialId is not supported
ArgumentNullException When setting this property: A non-optional argument was null
See Also