FamilyInstance.ToRoom Property

FamilyInstanceToRoom Property

The "To Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Room ToRoom { get; }
Public ReadOnly Property ToRoom As Room
	Get
public:
property Room^ ToRoom {
	Room^ get ();
}
member ToRoom : Room with get

Property Value

Room
The "To Room" set for the door or window in the last phase of the project. if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also if there is no target room assigned to the last phase, or phase does not apply to this FamilyInstance.
Remarks
Revit automatically calculates the "To Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "To Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom also can be used to swap the values.
See Also