FamilyInstance Class

FamilyInstance Class

This object represents a single instance of a family type, such as a single I beam.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBInstance
      Autodesk.Revit.DBFamilyInstance
        Autodesk.Revit.DBAnnotationSymbol
        Autodesk.Revit.DBMullion
        Autodesk.Revit.DBPanel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilyInstance : Instance
Public Class FamilyInstance
	Inherits Instance
public ref class FamilyInstance : public Instance
type FamilyInstance = 
    class
        inherit Instance
    end

The FamilyInstance type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCanFlipFacingProperty to test whether the orientation of family instance facing can be flipped.
Public propertyCanFlipHandProperty to test whether the orientation of family instance hand can be flipped.
Public propertyCanFlipWorkPlaneIdentifies if the instance can flip its work plane.
Public propertyCanRotateProperty to test whether the family instance can be rotated by 180 degrees.
Public propertyCanSplitIdentifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyExtensionUtilityProperty to check whether the instance can be extended and return the interface for extension operation.
Public propertyFacingFlippedProperty to test whether the orientation of family instance facing is flipped.
Public propertyFacingOrientationProperty to get the orientation of family instance facing.
Public propertyFromRoomThe "From Room" set for the door or window in the last phase of the project.
Public propertyFromRoomPhase 
Public propertyGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyHandFlippedProperty to test whether the orientation of family instance hand is flipped.
Public propertyHandOrientationProperty to get the orientation of family instance hand.
Public propertyHasSpatialElementCalculationPointIdentifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.
Public propertyHasSpatialElementFromToCalculationPointsIdentifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.
Public propertyHostIf the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public propertyHostFaceProperty to get the reference to the host face of family instance.
Public propertyHostParameterIf the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
Public propertyId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyInvisibleProperty to test whether the family instance is invisible.
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsSlantedColumn Indicates if the family instance is a slanted column.
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyIsWorkPlaneFlippedIdentifies if the instance's work plane is flipped.
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyLocationThis property is used to find the physical location of an instance within project.
(Overrides ElementLocation)
Public propertyMEPModelRetrieves the MEP model for the family instance.
Public propertyMirroredProperty to test whether the family instance is mirrored. (only one axis is flipped)
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyRoomThe room in which the instance is located (during the last phase of the project).
Public propertyRoomPhase 
Public propertySpaceThe space in which the instance is located (during the last phase of the project).
Public propertySpacePhase 
Public propertyStructuralMaterialIdIdentifies the material that defines the instance's structural analysis properties.
Public propertyStructuralMaterialTypeThis property returns the physical material from which the instance is made.
Public propertyStructuralTypeProvides the primary structural type of the instance, such as beam or column etc.
Public propertyStructuralUsageProvides the primary structural usage of the instance, such as brace, girder etc.
Public propertySuperComponentProperty to get the super component of current family instance.
Public propertySymbolReturns or changes the FamilySymbol object that represents the type of the instance.
Public propertyToRoomThe "To Room" set for the door or window in the last phase of the project.
Public propertyToRoomPhase 
Public propertyUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodAddCopingAdds a coping (cut) to a steel beam.
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues
(Inherited from Element)
Public methodflipFacingThe orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public methodFlipFromToRoom Flips the settings of "From Room" and "To Room" for the door or window instance.
Public methodflipHandThe orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public methodGetCopingIdsLists the elements currently used as coping cutters for this element.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetFamilyPointPlacementReferencesReturns the Point Placement References for the Family Instance.
Public methodGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetOriginalGeometry Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetReferenceByName Gets the family instance reference corresponding to the named reference plane in the instance's family.
Public methodGetReferenceName Gets the name of the reference plane in the family corresponding to the given family instance reference.
Public methodGetReferences Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Public methodGetReferenceType Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Public methodGetSpatialElementCalculationPointGets the location of the calculation point for this instance.
Public methodGetSpatialElementFromToCalculationPointsGets the locations for the calculation points for this instance.
Public methodGetSubComponentIdsGets the sub component ElementIds of the current family instance.
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetSweptProfileGets the object that describes the profile that is swept along the driving curve for this instance.
Public methodGetTotalTransform Gets the total transform, which includes the true north transform for instances like import instances.
(Inherited from Instance)
Public methodGetTransform Gets the transform of the instance.
(Inherited from Instance)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasModifiedGeometryIdentifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodHasSweptProfileIndicates if this instance can be represented as a swept profile.
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodRemoveCopingRemoves a coping (cut) from a steel beam.
Public methodrotateThe family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public methodSetCopingIds 
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSplitSplits the family instance element at a point on its defining curve.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.
See Also