FamilyInstance Class

FamilyInstance Class

This object represents a single instance of a family type, such as a single I beam.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBInstance
      Autodesk.Revit.DBFamilyInstance
        Autodesk.Revit.DBAnnotationSymbol
        Autodesk.Revit.DBMullion
        Autodesk.Revit.DBPanel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilyInstance : Instance
Public Class FamilyInstance
	Inherits Instance
public ref class FamilyInstance : public Instance
type FamilyInstance = 
    class
        inherit Instance
    end

The FamilyInstance type exposes the following members.

Properties
 NameDescription
Public propertyCanFlipFacingProperty to test whether the orientation of family instance facing can be flipped.
Public propertyCanFlipHandProperty to test whether the orientation of family instance hand can be flipped.
Public propertyCanFlipWorkPlaneIdentifies if the instance can flip its work plane.
Public propertyCanRotateProperty to test whether the family instance can be rotated by 180 degrees.
Public propertyCanSplitIdentifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).
Public propertyExtensionUtilityProperty to check whether the instance can be extended and return the interface for extension operation.
Public propertyFacingFlippedProperty to test whether the orientation of family instance facing is flipped.
Public propertyFacingOrientationProperty to get the orientation of family instance facing.
Public propertyFromRoomThe "From Room" set for the door or window in the last phase of the project.
Public propertyFromRoomPhase 
Public propertyHandFlippedProperty to test whether the orientation of family instance hand is flipped.
Public propertyHandOrientationProperty to get the orientation of family instance hand.
Public propertyHasSpatialElementCalculationPointIdentifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.
Public propertyHasSpatialElementFromToCalculationPointsIdentifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.
Public propertyHostIf the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public propertyHostFaceProperty to get the reference to the host face of family instance.
Public propertyHostParameterIf the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
Public propertyInvisibleProperty to test whether the family instance is invisible.
Public propertyIsSlantedColumn Indicates if the family instance is a slanted column.
Public propertyIsWorkPlaneFlippedIdentifies if the instance's work plane is flipped.
Public propertyLocationThis property is used to find the physical location of an instance within project.
(Overrides ElementLocation)
Public propertyMEPModelRetrieves the MEP model for the family instance.
Public propertyMirroredProperty to test whether the family instance is mirrored. (only one axis is flipped)
Public propertyRoomThe room in which the instance is located (during the last phase of the project).
Public propertyRoomPhase 
Public propertySpaceThe space in which the instance is located (during the last phase of the project).
Public propertySpacePhase 
Public propertyStructuralMaterialIdIdentifies the material that defines the instance's structural analysis properties.
Public propertyStructuralMaterialTypeThis property returns the physical material from which the instance is made.
Public propertyStructuralTypeProvides the primary structural type of the instance, such as beam or column etc.
Public propertyStructuralUsageProvides the primary structural usage of the instance, such as brace, girder etc.
Public propertySuperComponentProperty to get the super component of current family instance.
Public propertySymbolReturns or changes the FamilySymbol object that represents the type of the instance.
Public propertyToRoomThe "To Room" set for the door or window in the last phase of the project.
Public propertyToRoomPhase 
Top
Methods
 NameDescription
Public methodAddCopingAdds a coping (cut) to a steel beam.
Public methodflipFacingThe orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public methodFlipFromToRoom Flips the settings of "From Room" and "To Room" for the door or window instance.
Public methodflipHandThe orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public methodGetCopingIdsLists the elements currently used as coping cutters for this element.
Public methodGetFamilyPointPlacementReferencesReturns the Point Placement References for the Family Instance.
Public methodGetOriginalGeometry Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public methodGetReferenceByName Gets the family instance reference corresponding to the named reference plane in the instance's family.
Public methodGetReferenceName Gets the name of the reference plane in the family corresponding to the given family instance reference.
Public methodGetReferences Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Public methodGetReferenceType Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Public methodGetSpatialElementCalculationPointGets the location of the calculation point for this instance.
Public methodGetSpatialElementFromToCalculationPointsGets the locations for the calculation points for this instance.
Public methodGetSubComponentIdsGets the sub component ElementIds of the current family instance.
Public methodGetSweptProfileGets the object that describes the profile that is swept along the driving curve for this instance.
Public methodHasModifiedGeometryIdentifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
Public methodHasSweptProfileIndicates if this instance can be represented as a swept profile.
Public methodRemoveCopingRemoves a coping (cut) from a steel beam.
Public methodrotateThe family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public methodSetCopingIds 
Public methodSplitSplits the family instance element at a point on its defining curve.
Top
Remarks
Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.
See Also