FamilyInstance.GetSweptProfile Method

FamilyInstanceGetSweptProfile Method

Gets the object that describes the profile that is swept along the driving curve for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public SweptProfile GetSweptProfile()
Public Function GetSweptProfile As SweptProfile
public:
SweptProfile^ GetSweptProfile()
member GetSweptProfile : unit -> SweptProfile 

Return Value

SweptProfile
A swept profile.
Exceptions
ExceptionCondition
InapplicableDataExceptionThrown if this instance does not have a swept profile.
See Also