FamilyInstance.AddCoping Method

FamilyInstanceAddCoping Method

Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool AddCoping(
	FamilyInstance cutter
)
Public Function AddCoping ( 
	cutter As FamilyInstance
) As Boolean
public:
bool AddCoping(
	FamilyInstance^ cutter
)
member AddCoping : 
        cutter : FamilyInstance -> bool 

Parameters

cutter  FamilyInstance
A steel beam or column. May not be or itself.

Return Value

Boolean
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when 'cutter' is .
ArgumentExceptionThrown when 'cutter' refers to this instance.
InvalidOperationExceptionThrown when regeneration fails.
Remarks
This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.
See Also