ExternalResourceBrowserData.AddResource(String) Method

ExternalResourceBrowserDataAddResource(String) Method

Adds an external resource to the folder path by supplying the resource name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddResource(
	string resourceName
)
Public Sub AddResource ( 
	resourceName As String
)
public:
void AddResource(
	String^ resourceName
)
member AddResource : 
        resourceName : string -> unit 

Parameters

resourceName  String
The unique short name of external resource.
Exceptions
ExceptionCondition
ArgumentException The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
ArgumentNullException A non-optional argument was null
See Also