Revit 2025.3 API
Dockable |
Identifier for a pane that participates in the Revit docking window system.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The DockablePaneId type exposes the following members.

Name | Description | |
---|---|---|
![]() | DockablePaneId | Creates a new DockablePaneId instance. |


Name | Description | |
---|---|---|
![]() | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum) |
![]() | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(DockablePaneId, DockablePaneId) | Compares two DockablePaneId instances. |
![]() ![]() | Inequality(DockablePaneId, DockablePaneId) | Compares two DockablePaneId instances. |
See Also