Revit 2025.3 API
Table |
Sets a column's cell type
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetCellType( int nCol, CellType type )
Public Sub SetCellType ( nCol As Integer, type As CellType )
public: void SetCellType( int nCol, CellType type )
member SetCellType : nCol : int * type : CellType -> unit
Parameters
- nCol Int32
- type CellType

Exception | Condition |
---|---|
ArgumentException | A CellType.CustomField can't be set. -or- The given column number nCol is invalid. |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections. |
See Also