ViewDisplayModel Class

ViewDisplayModel Class

Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBViewDisplayModel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewDisplayModel : IDisposable
Public Class ViewDisplayModel
	Implements IDisposable
public ref class ViewDisplayModel : IDisposable
type ViewDisplayModel = 
    class
        interface IDisposable
    end

The ViewDisplayModel type exposes the following members.

Properties
 NameDescription
Public propertyEnableSilhouettes True to show silhouettes edges. False to disable showing them.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyShowHiddenLines True to enable hidden lines. False to disable showing them.
Public propertySilhouetteEdgesGStyleId Style ID for silhouette edges
Public propertySmoothEdges True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public propertyTransparency The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ViewDisplayModel
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also