Face.Intersect(Curve) Method

FaceIntersect(Curve) Method

Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public SetComparisonResult Intersect(
	Curve curve
)
Public Function Intersect ( 
	curve As Curve
) As SetComparisonResult
public:
SetComparisonResult Intersect(
	Curve^ curve
)
member Intersect : 
        curve : Curve -> SetComparisonResult 

Parameters

curve  Curve
The specified curve to intersect with this face.

Return Value

SetComparisonResult
  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.
Exceptions
ExceptionCondition
ArgumentNullException The curve is .
InvalidOperationException The intersection calculation fails.
See Also