Revit 2025.3 API
Export |
Retrieves the GUID representing this document in exported gbXML files.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Guid GetGBXMLDocumentId( Document document )
Public Shared Function GetGBXMLDocumentId ( document As Document ) As Guid
public: static Guid GetGBXMLDocumentId( Document^ document )
static member GetGBXMLDocumentId : document : Document -> Guid
Parameters
- document Document
- The document.
Return Value
GuidThe value of the GUID representing this document in gbXML export.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This id can be used to cross-reference different gbXML exports from the same document.
See Also