Revit 2025.3 API
IFCCategory |
Sets the mapping template element to be the active mapping template in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetActiveTemplate( Document document )
Public Sub SetActiveTemplate ( document As Document )
public: void SetActiveTemplate( Document^ document )
member SetActiveTemplate : document : Document -> unit
Parameters
- document Document
- The document to set.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |
See Also