Revit 2025.3 API
Curve |
Sets the geometry of the curve element.
After the curve geometry is set, other nearby curves may join to the new curve geometry.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetGeometryCurve( Curve curve, bool overrideJoins )
Public Sub SetGeometryCurve ( curve As Curve, overrideJoins As Boolean )
public: void SetGeometryCurve( Curve^ curve, bool overrideJoins )
member SetGeometryCurve : curve : Curve * overrideJoins : bool -> unit
Parameters
- curve Curve
- The new curve.
- overrideJoins Boolean
- An option to specify whether or not existing joins will affect setting the geometry of the CurveElement. Setting this parameter to false is essentially the same as directly setting the GeometryCurve property.

Exception | Condition |
---|---|
ArgumentNullException | Thrown if the argument is . |
ArgumentException | Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints. |
See Also