LinePattern Class

LinePattern Class

Represents a line pattern definition.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBLinePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LinePattern : IDisposable
Public Class LinePattern
	Implements IDisposable
public ref class LinePattern : IDisposable
type LinePattern = 
    class
        interface IDisposable
    end

The LinePattern type exposes the following members.

Constructors
 NameDescription
Public methodLinePattern Creates a simple line pattern.
Public methodLinePattern(String) Creates a line pattern with given name.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName Line pattern name.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LinePattern
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetSegments Gets the sequence of segments that defines this line pattern.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetSegments 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A line pattern is a pattern of dashes and dots used to control the way the lines of an object are drawn in Revit. Line patterns are used in the definition of GraphicsStyle objects. A line pattern is defined by a repeating sequence segments. Each segment is a dash, a dot or a space. A line pattern definition must contain an even number of segments, starting with a visible segment (a dash or a dot) and alternating between visible segments and spaces.
See Also