DirectShapeType.SetOptions Method

DirectShapeTypeSetOptions Method

Sets the options to use for this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetOptions(
	DirectShapeTypeOptions options
)
Public Sub SetOptions ( 
	options As DirectShapeTypeOptions
)
public:
void SetOptions(
	DirectShapeTypeOptions^ options
)
member SetOptions : 
        options : DirectShapeTypeOptions -> unit 

Parameters

options  DirectShapeTypeOptions
Options to use for this DirectShapeType.
Exceptions
ExceptionCondition
ArgumentException The DirectShapeTypeOptions provided are not valid for this DirectShapeType.
ArgumentNullException A non-optional argument was null
Remarks
The new options take effect immediately.
See Also