LayerModifier Class

LayerModifier Class

A modifier used to designate extra strings to appear in the exported layer name.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBLayerModifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayerModifier : IDisposable
Public Class LayerModifier
	Implements IDisposable
public ref class LayerModifier : IDisposable
type LayerModifier = 
    class
        interface IDisposable
    end

The LayerModifier type exposes the following members.

Constructors
 NameDescription
Public methodLayerModifier Constructs a new LayerModifier with default values.
Public methodLayerModifier(ModifierType, String) Constructs a new LayerModifier with modifierType and separator.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyModifierType The modifier type of LayerModifier.
Public propertySeparator The separator string that will follow this modifier in the export layer name.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LayerModifier
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A modifier consists of a type (from ModifierType and an optional separator. Apply a modifier to one or more ExportLayerInfo objects to modify the layer name that will be assigned when a Revit object is exported.
See Also