Revit 2025.3 API
DocumentGet |
Gets a space containing the point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Space GetSpaceAtPoint( XYZ point, Phase phase )
Public Function GetSpaceAtPoint ( point As XYZ, phase As Phase ) As Space
public: Space^ GetSpaceAtPoint( XYZ^ point, Phase^ phase )
member GetSpaceAtPoint : point : XYZ * phase : Phase -> Space
Parameters
Return Value
SpaceThe space containing the point.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the point is . |
ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue. |

If phase is , it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns .
See Also