BoundingBoxUV.IsSet Property

BoundingBoxUVIsSet Property

Indicates whether the BoundingBoxUV is set or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsSet { get; }
Public ReadOnly Property IsSet As Boolean
	Get
public:
property bool IsSet {
	bool get ();
}
member IsSet : bool with get

Property Value

Boolean
Remarks
An unset BoundingBoxUV has its lower-left corner to the right of (and above) its upper-right corner (this is an arbitrary internal representation). It means that it is empty and has never been initialized. If someone using the API creates a Plane via one of the Plane.Create() methods, for example, the Plane will not have its envelope set, so Surface.GetBoundingBoxUV() would return an empty BoundingBoxUV.
See Also