Revit 2025.3 API
Numeric |
Constructs a NumericRevisionSettings object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public NumericRevisionSettings( int startNumber, string prefix, string suffix )
Public Sub New ( startNumber As Integer, prefix As String, suffix As String )
public: NumericRevisionSettings( int startNumber, String^ prefix, String^ suffix )
new : startNumber : int * prefix : string * suffix : string -> NumericRevisionSettings
Parameters
- startNumber Int32
- The start number for the sequence.
- prefix String
- The prefix string for each revision number in the sequence.
- suffix String
- The suffix string for each revision number in the sequence.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for startNumber is negative. |

The starting number parameter accepts any non-negative integer, and
the prefix and suffix strings are allowed to be empty.
See Also