Revit 2025.3 API
Fabrication |
Creates a fabrication part type element based on a specific fabrication servic button and condition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FabricationPartType Create( Document document, FabricationServiceButton button, int condition )
Public Shared Function Create ( document As Document, button As FabricationServiceButton, condition As Integer ) As FabricationPartType
public: static FabricationPartType^ Create( Document^ document, FabricationServiceButton^ button, int condition )
static member Create : document : Document * button : FabricationServiceButton * condition : int -> FabricationPartType
Parameters
- document Document
- The document.
- button FabricationServiceButton
- The fabrication service button.
- condition Int32
- The condition index.
Return Value
FabricationPartTypeThe created fabrication part type element.

Exception | Condition |
---|---|
ArgumentException | Fabrication service button contains invalid fittings. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount. |
InvalidOperationException | The fabrication part type already exists. |
See Also