ExternalResourceBrowserData.AddSubFolder(String) Method

ExternalResourceBrowserDataAddSubFolder(String) Method

Adds a subfolder to the folder path with the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddSubFolder(
	string folderName
)
Public Sub AddSubFolder ( 
	folderName As String
)
public:
void AddSubFolder(
	String^ folderName
)
member AddSubFolder : 
        folderName : string -> unit 

Parameters

folderName  String
The name of the folder.
Exceptions
ExceptionCondition
ArgumentException The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
ArgumentNullException A non-optional argument was null
See Also