IFCCategoryTemplate.FindByName Method

IFCCategoryTemplateFindByName Method

Returns mapping template element by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static IFCCategoryTemplate FindByName(
	Document document,
	string name
)
Public Shared Function FindByName ( 
	document As Document,
	name As String
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ FindByName(
	Document^ document, 
	String^ name
)
static member FindByName : 
        document : Document * 
        name : string -> IFCCategoryTemplate 

Parameters

document  Document
The document to find the mapping template with the specified name.
name  String
Name of the mapping template to find.

Return Value

IFCCategoryTemplate
The mapping template element, or if not found.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also