RebarRoundingManager.SegmentLengthRoundingMethod Property

RebarRoundingManagerSegmentLengthRoundingMethod Property

Identifies the segment length rounding method

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RoundingMethod SegmentLengthRoundingMethod { get; set; }
Public Property SegmentLengthRoundingMethod As RoundingMethod
	Get
	Set
public:
property RoundingMethod SegmentLengthRoundingMethod {
	RoundingMethod get ();
	void set (RoundingMethod value);
}
member SegmentLengthRoundingMethod : RoundingMethod with get, set

Property Value

RoundingMethod
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException When setting this property: IsActiveOnElement property is false.
See Also