RebarRoundingManager Class

RebarRoundingManager Class

Provides access to element reinforcement roundings overrides.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureReinforcementRoundingManager
    Autodesk.Revit.DB.StructureRebarRoundingManager

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarRoundingManager : ReinforcementRoundingManager
Public Class RebarRoundingManager
	Inherits ReinforcementRoundingManager
public ref class RebarRoundingManager : public ReinforcementRoundingManager
type RebarRoundingManager = 
    class
        inherit ReinforcementRoundingManager
    end

The RebarRoundingManager type exposes the following members.

Properties
 NameDescription
Public propertyApplicableReinforcementRoundingSource Identifies the source of the rounding settings for this element.
Public propertyApplicableSegmentLengthRounding The applicable rounding for shared parameters used by rebar.
Public propertyApplicableSegmentLengthRoundingMethod The applicable rounding method for shared parameters used by rebar.
Public propertyApplicableTotalLengthRounding The applicable rounding for Bar Length and Total Bar Length parameters.
Public propertyApplicableTotalLengthRoundingMethod The applicable rounding method for Bar Length and Total Bar Length parameters.
Public propertyElement The owner of the reinforcement rounding overrides.
(Inherited from ReinforcementRoundingManager)
Public propertyIsActiveOnElement Defines whether reinforcement rounding is activated for the particular element.
(Inherited from ReinforcementRoundingManager)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ReinforcementRoundingManager)
Public propertySegmentLengthRounding The rounding for shared parameters used by rebar.
Public propertySegmentLengthRoundingMethod Identifies the segment length rounding method
Public propertyTotalLengthRounding The rounding for Bar Length and Total Bar Length parameters.
Public propertyTotalLengthRoundingMethod Identifies the total length rounding method
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ReinforcementRoundingManager)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLengthUnitTypeId Gets the identifier of the length unit quantifying the reinforcement rounding values.
(Inherited from ReinforcementRoundingManager)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
An instance of this class can be obtained from specific RebarTypes or individual Rebar or RebarInSystem elements to apply overrides different from the global settings for the project.
See Also