RebarRoundingManager.ApplicableSegmentLengthRoundingMethod Property

RebarRoundingManagerApplicableSegmentLengthRoundingMethod Property

The applicable rounding method for shared parameters used by rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RoundingMethod ApplicableSegmentLengthRoundingMethod { get; }
Public ReadOnly Property ApplicableSegmentLengthRoundingMethod As RoundingMethod
	Get
public:
property RoundingMethod ApplicableSegmentLengthRoundingMethod {
	RoundingMethod get ();
}
member ApplicableSegmentLengthRoundingMethod : RoundingMethod with get

Property Value

RoundingMethod
Remarks
IsActiveOnElement property of ReinforcementSettings RebarRoundingManager has to be true. ApplicableSegmentLengthRoundingMethod is meaningless if ReinforcementSettings RebarRoundingManager IsActiveOnElement is false.
See Also