ElementTransformUtils.MirrorElements Method

ElementTransformUtilsMirrorElements Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static IList<ElementId> MirrorElements(
	Document document,
	ICollection<ElementId> elementsToMirror,
	Plane plane,
	bool mirrorCopies
)
Public Shared Function MirrorElements ( 
	document As Document,
	elementsToMirror As ICollection(Of ElementId),
	plane As Plane,
	mirrorCopies As Boolean
) As IList(Of ElementId)
public:
static IList<ElementId^>^ MirrorElements(
	Document^ document, 
	ICollection<ElementId^>^ elementsToMirror, 
	Plane^ plane, 
	bool mirrorCopies
)
static member MirrorElements : 
        document : Document * 
        elementsToMirror : ICollection<ElementId> * 
        plane : Plane * 
        mirrorCopies : bool -> IList<ElementId> 

Parameters

document  Document
 
elementsToMirror  ICollectionElementId
 
plane  Plane
 
mirrorCopies  Boolean
 

Return Value

IListElementId
See Also