ElementTransformUtils Class

ElementTransformUtils Class

A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementTransformUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ElementTransformUtils
Public NotInheritable Class ElementTransformUtils
public ref class ElementTransformUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementTransformUtils = class end

The ElementTransformUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberCanMirrorElement Determines whether element can be mirrored.
Public methodStatic memberCanMirrorElements 
Public methodStatic memberCopyElement Copies an element and places the copy at a location indicated by a given transformation.
Public methodStatic memberCopyElements(Document, ICollectionElementId, XYZ) 
Public methodStatic memberCopyElements(Document, ICollectionElementId, Document, Transform, CopyPasteOptions) 
Public methodStatic memberCopyElements(View, ICollectionElementId, View, Transform, CopyPasteOptions) 
Public methodStatic memberGetTransformFromViewToView Returns a transformation that is applied to elements when copying from one view to another view.
Public methodStatic memberMirrorElement Creates a mirrored copy of an element about a given plane.
Public methodStatic memberMirrorElements 
Public methodStatic memberMoveElement Moves one element by a given transformation.
Public methodStatic memberMoveElements 
Public methodStatic memberRotateElement Rotates an element about the given axis and angle.
Public methodStatic memberRotateElements 
Top
See Also