ElementTransformUtils.MirrorElement Method

ElementTransformUtilsMirrorElement Method

Creates a mirrored copy of an element about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void MirrorElement(
	Document document,
	ElementId elementToMirror,
	Plane plane
)
Public Shared Sub MirrorElement ( 
	document As Document,
	elementToMirror As ElementId,
	plane As Plane
)
public:
static void MirrorElement(
	Document^ document, 
	ElementId^ elementToMirror, 
	Plane^ plane
)
static member MirrorElement : 
        document : Document * 
        elementToMirror : ElementId * 
        plane : Plane -> unit 

Parameters

document  Document
The document that owns the element.
elementToMirror  ElementId
The element to mirror.
plane  Plane
The mirror plane.
Exceptions
ExceptionCondition
ArgumentException elementToMirror cannot be mirrored. -or- The element elementToMirror does not exist in the document -or- The input element is a Sketch member and there is no Sketch in the edit mode to place this element in.
ArgumentNullException A non-optional argument was null
See Also