ElementTransformUtils.CanMirrorElement Method

ElementTransformUtilsCanMirrorElement Method

Determines whether element can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool CanMirrorElement(
	Document ADoc,
	ElementId elemId
)
Public Shared Function CanMirrorElement ( 
	ADoc As Document,
	elemId As ElementId
) As Boolean
public:
static bool CanMirrorElement(
	Document^ ADoc, 
	ElementId^ elemId
)
static member CanMirrorElement : 
        ADoc : Document * 
        elemId : ElementId -> bool 

Parameters

ADoc  Document
The document where the element reside.
elemId  ElementId
The element identified by id.

Return Value

Boolean
True if the element can be mirrored.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also