MeshFromGeometryOperationResult.GetMesh Method

MeshFromGeometryOperationResultGetMesh Method

This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Mesh GetMesh()
Public Function GetMesh As Mesh
public:
Mesh^ GetMesh()
member GetMesh : unit -> Mesh 

Return Value

Mesh
Mesh which built.
Exceptions
ExceptionCondition
InvalidOperationException The Mesh has already been accessed by a previous GetMesh() call, and is no longer available for use.
See Also