Mesh Class

Mesh Class

A triangular mesh.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBMesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Mesh : GeometryObject
Public Class Mesh
	Inherits GeometryObject
public ref class Mesh : public GeometryObject
type Mesh = 
    class
        inherit GeometryObject
    end

The Mesh type exposes the following members.

Properties
 NameDescription
Public propertyDistributionOfNormals Indicates the distribution of normal vectors along the tessellated mesh surface.
Public propertyGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsClosed Indicates whether the mesh is closed.
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyMaterialElementIdElement ID of the material from which this mesh is composed.
Public propertyNumberOfNormals The number of normals associated with the mesh.
Public propertyNumTrianglesThe number of triangles that the mesh contains.
Public propertyTransformedTransforms this mesh and returns the result.
Public propertyTriangleRetrieves a specific triangle.
Public propertyVerticesRetrieves all vertices used to define this mesh. Intended for indexed access.
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodComputeSurfaceArea Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetNormal Returns a normal unit vector at the given index.
Public methodGetNormals Returns all normals assigned to the mesh.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Meshes are generated during triangulation of faces. They can also be encountered directly in Revit geometry (typically imported geometry). Meshes contain a single array of Vertices, and a corresponding array of triangles. Triangles can be accessed by index from TriangleInt32, and reference 3 vertices from the Vertices array.
See Also