Revit 2025.3 API
Unit |
A utility class for formatting and parsing numbers with units.

SystemObject
Autodesk.Revit.DBUnitFormatUtils
Autodesk.Revit.DBUnitFormatUtils
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The UnitFormatUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string. |
![]() ![]() | Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string. |
![]() ![]() | TryParse(Units, ForgeTypeId, String, Double) | Parses a formatted string into a number with units if possible. |
![]() ![]() | TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) | Parses a formatted string into a number with units if possible. |
![]() ![]() | TryParse(Units, ForgeTypeId, String, Double, String) | Parses a formatted string into a number with units if possible. |
![]() ![]() | TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) | Parses a formatted string into a number with units if possible. |
See Also