Revit 2025.3 API
Unit |
Parses a formatted string into a number with units if possible.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool TryParse( Units units, ForgeTypeId specTypeId, string stringToParse, ValueParsingOptions valueParsingOptions, out double value )
Public Shared Function TryParse ( units As Units, specTypeId As ForgeTypeId, stringToParse As String, valueParsingOptions As ValueParsingOptions, <OutAttribute> ByRef value As Double ) As Boolean
public: static bool TryParse( Units^ units, ForgeTypeId^ specTypeId, String^ stringToParse, ValueParsingOptions^ valueParsingOptions, [OutAttribute] double% value )
static member TryParse : units : Units * specTypeId : ForgeTypeId * stringToParse : string * valueParsingOptions : ValueParsingOptions * value : float byref -> bool
Parameters
- units Units
- The units formatting settings, typically obtained from Document.GetUnits().
- specTypeId ForgeTypeId
- Identifier of the target spec for the value.
- stringToParse String
- The string to parse.
- valueParsingOptions ValueParsingOptions
- Additional parsing options.
- value Double
- The parsed value. Ignore this value if the function returns false.
Return Value
BooleanTrue if the string can be parsed, false otherwise.

Exception | Condition |
---|---|
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId). |
ArgumentNullException | A non-optional argument was null |
See Also