ElementDesignOptionFilter Class

ElementDesignOptionFilter Class

A filter used to find elements contained within a particular design option.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBElementDesignOptionFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementDesignOptionFilter : ElementQuickFilter
Public Class ElementDesignOptionFilter
	Inherits ElementQuickFilter
public ref class ElementDesignOptionFilter : public ElementQuickFilter
type ElementDesignOptionFilter = 
    class
        inherit ElementQuickFilter
    end

The ElementDesignOptionFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementDesignOptionFilter(ElementId) Constructs a new instance of a filter to match elements contained within a particular design option.
Public methodElementDesignOptionFilter(ElementId, Boolean) Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.
Top
Properties
 NameDescription
Public propertyDesignOptionId The design option id.
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also