Revit 2025.3 API
External |
Indicates whether the IExternalResourceUIServer has reported errors
for this ExternalResourceLoadData. This value can be set by the
IExternalResourceUIServer in HandleLoadResourceResults().
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool ErrorsReported { get; set; }
Public Property ErrorsReported As Boolean Get Set
public: property bool ErrorsReported { bool get (); void set (bool value); }
member ErrorsReported : bool with get, set
Property Value
Boolean
For Revit links specifically, Revit will check this value to see if it should report errors about a given link in the Unresolved References dialog. An IExternalResourceUIServer can set this value to true to avoid redundant messages.
Note that it is possible for Revit to encounter errors internally even if the server successfully provides a reference. In general, this value should only be set to true if the server has reported an error condition.
See Also