ExternalResourceLoadData Class

ExternalResourceLoadData Class

This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalResourceLoadData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExternalResourceLoadData : IDisposable
Public Class ExternalResourceLoadData
	Implements IDisposable
public ref class ExternalResourceLoadData : IDisposable
type ExternalResourceLoadData = 
    class
        interface IDisposable
    end

The ExternalResourceLoadData type exposes the following members.

Properties
 NameDescription
Public propertyErrorsReported Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public propertyExternalResourceType The ExternalResourceType for which Revit is requesting data from the server.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLoadStatus The success or failure status of the load attempt.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternalResourceLoadData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetExternalResourceReference Returns the ExternalResourceReference that identifies which resource should be loaded.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLoadContent Returns the ExternalResourceLoadContent resulting from this load operation.
Public methodGetLoadContext Returns an object containing information about the context of the load operation.
Public methodGetLoadRequestId Returns the load operation GUID.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also